BLACK FRIDAY IN JULY SALE

Save on laptops, tablets, HDTVs and more.

Shop now ›

Friday–Saturday.

2  items found for "

Lego Harry Potter 1-4 Pc Exe Crashes

" in  All Categories

Narrow Your Results

1 - 2 of 2
View:
Sort by:

Game download

Lego Harry Potter: Years 1-4

SKU: 1000000011
Platform: Windows
Rating: E10+(Everyone 10+)
Release Date: 6/29/2010
Customer Reviews:   Be the first to write a review.
Everyone 10+
Ages 10+. May contain cartoon, fantasy or mild violence, mild language, and/or suggestive themes. Check below for details.
1-2 Players
Gameplay designed for 1-2 people.
Co-op Gameplay
Allows split screen or online gameplay with multiple players.
Dolby Digital
Compatible with Dolby Digital audio decoders in home theater systems.
Non-returnable. Download in US only.
Check Availability & Requirements ›
Close

Availability & Requirements

Digital Download:  Usually available in 30 min. in your BestBuy.com Digital Library, but it could take up to 4 hours.
How It Works

Purchase Rights   Unlimited play. Install on 1 PC

Download and System Requirements:

  • Windows 7, Windows Vista with Service Pack 1 or Windows XP
  • Microsoft Internet Explorer 7; Firefox 3.5; Google Chrome

Check Requirements ›


Game download

LEGO Harry Potter: Years 5-7

SKU: 1000001391
Platform: Windows
Rating: E(Everyone)
Release Date: 11/18/2011
Customer Reviews:   Be the first to write a review.
Everyone
May contain minimal cartoon, fantasy or mild violence, and/or mild language. Check below for details
1-2 Players
Gameplay designed for 1-2 people.
Co-op Gameplay
Allows split screen or online gameplay with multiple players.
Co-op Gameplay
Allows split screen or online gameplay with multiple players.
Non-returnable. Download in US only.
Check Availability & Requirements ›
Close

Availability & Requirements

Digital Download:  Usually available in 30 min. in your BestBuy.com Digital Library, but it could take up to 4 hours.
How It Works

Purchase Rights   Unlimited play. Install on 1 PC

Download and System Requirements:

  • Windows 7, Windows Vista with Service Pack 1 or Windows XP
  • Microsoft Internet Explorer 7; Firefox 3.5; Google Chrome

Check Requirements ›

1 - 2 of 2
View:
Sort by: