Main Content

Customer Ratings & Reviews

TP-Link - Archer C50 AC1200 AC Dual-Band Router - Black-Front_Standard

Customer rating

Rating 4.5 out of 5 stars with 86 reviews

  • 30%
95%
would recommend to a friend

Pros

Cons

Customer ratings & reviews

Filter:
Page 1, showing1-2 of 2 Reviews
  • Rating: 2 out of 5 stars

    Highest speed only 100 mps not 300

    Posted
    Figaro

    The Archer C50 only gives 100 mps, not 300. Which may be fast enough for you but I have 200 mps available. Check it’s specs and you will see its interface is 10x100.

    No, I would not recommend this to a friend

    • Brand response

      TPLinkSupport

      Hi Figaro,

      Thank you for your review. In order to provide customers with options that best fit their networking needs, we offer a variety of products. For customers who subscribe to Internet speed plans of 100Mbps or less, and utilize a large number of simultaneous wireless devices, this router will perform exceptionally. However, for Internet speeds plans that exceed 100Mbps, the Archer C1200 has similar features but also includes wired Gigabit Ethernet ports that support speeds of up to 1000Mbps.

      https://www.bestbuy.com/site/tp-link-ac1200-dual-band-wi-fi-router-black/5844811.p?skuId=5844811

      Our Support Team is always happy to answer any questions you might have about our products. Please feel free to e-mail USSupportTeam@TP-Link.com and we'll gladly have a Support Agent follow up with you directly.

      Best Regards,
      TP-Link Support tplink

  • Rating: 2 out of 5 stars

    Confused over product

    Posted
    Realg53
    • Verified PurchaserVerified Purchase
    • My Best Buy® MemberMember

    I could get on line with the product but could not get it it paired with the computer, modem and tv to receive the necessary wi-fi signal needed to provide the desired results.

    No, I would not recommend this to a friend

    • Brand response

      TPLinkSupport

      Hello,

      Thank you for your review and feedback.

      If you're experiencing difficulty connecting your wireless devices to the router, we first recommend ensuring the Wi-Fi is enabled and broadcasting. Please make sure the 2.4G and 5G Wi-Fi LEDs are on and flashing. If they are not, please press the "Wi-Fi" button behind the router for 1-2 seconds, then release it; the 2.4G and 5G LEDs should come on.

      However, if your 2.4G and 5G LEDs are already flashing, but you're still having trouble connecting, please ensure you're selecting the correct Wi-Fi network name, and entering the correct password when trying to connect. If you haven't created a custom Wi-Fi name and password, please refer to the label beneath the router for the default Wi-Fi information.

      However, if you created a custom Wi-Fi name and password, you'll need to use this information when connecting.

      If you have any further questions or concerns in the future, please feel free to contact our Support Team at the number and/or e-mail address provided below, and an available Support Agent will be happy to assist you.

      Best Regards,

      TP-Link Customer Support
      (866) 225-8139
      USSupportTeam@TP-Link.com